Limited functionality of Webspace Recovery
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Mar 25, 2020 - 13:56 GMT
Update
We are still working on resolving the technical issue.
Posted Mar 24, 2020 - 21:49 GMT
Identified
Some customers may face issues while using Webspace Recovery.
Posted Mar 24, 2020 - 18:26 GMT
This incident affected: Website Builder and Hosting (Web Hosting).