Incident Report for HiDrive
Incident Report for ionos.co.uk
Resolved
The systems are stable and all services are functioning normally again.
Posted Feb 18, 2020 - 16:08 GMT
Update
Our technicians are currently working on resolving this issue.
Posted Feb 17, 2020 - 17:20 GMT
Identified
We have received reports that some of our customers may be experiencing issues when attempting to log into HiDrive
Posted Feb 16, 2020 - 00:42 GMT
This incident affected: Online Storage & Backup (HiDrive).