Technical issues in our email systems

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Mar 04, 2026 - 10:24 GMT

Update

Our technicians are currently working on resolving this issue.
Posted Mar 04, 2026 - 08:37 GMT

Identified

Some customers are experiencing issues sending E-mails.
Posted Mar 04, 2026 - 08:11 GMT
This incident affected: Email (Microsoft Exchange, Sending Emails).