Support Hotline cannot be reached
Incident Report for ionos.co.uk
Resolved
The disruption affecting the Support Line has been resolved. It is now functioning normally again.
Posted Nov 17, 2021 - 17:02 GMT
Identified
Due to a technical disruption, the support line 0333 336 5691 and 0800 021 1693 are temporarily unavailable. Please call us back later or send us an E-mail to support@ionos.co.uk or contact us via chat
Posted Nov 17, 2021 - 16:42 GMT
This incident affected: Customer Service (Customer Hotline).