Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Feb 13, 2020 - 09:34 GMT
Identified
Some customers may be unable to view their invoice in the Control Panel
Posted Feb 13, 2020 - 08:20 GMT
This incident affected: Contract Management (Billing Service).