Cancellation hotline may not be reached

Incident Report for ionos.co.uk

Resolved

The disruption affecting the Cancellation Line has been resolved. It is now functioning normally again.
Posted Jun 10, 2025 - 12:47 BST

Identified

We are currently experiencing technical difficulties with following phone number 0800 917 6273, and it is not reachable at this time.
If you need to e.g. cancel your service, please dial +1 816 621 4831 as an alternative contact number (may incur additional charge).
Posted Jun 10, 2025 - 12:34 BST
This incident affected: Customer Service (Customer Hotline).