Incident Report for Webmail
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted May 18, 2020 - 20:49 BST
Identified
Some customers may face issues while using their Webmail
Posted May 18, 2020 - 18:56 BST
This incident affected: Email (Webmail).