Disruption in logging into the Webmail
Incident Report for ionos.co.uk
Resolved
The systems are stable and all services are functioning normally again. We apologise for the inconvenience caused and thank you for your patience.
Posted Sep 30, 2020 - 15:50 BST
Identified
Some customers may experience issues while using their Webmail
Posted Sep 30, 2020 - 14:56 BST
This incident affected: Email (Webmail).