Limited functionality of product Webmail

Incident Report for ionos.co.uk

Update

We are continuing to work on a fix for this issue.
Posted Jul 27, 2026 - 16:09 BST

Identified

We are working on a quick solution and apologise for any inconvenience this may cause
Posted Jul 27, 2026 - 14:55 BST

Investigating

Some customers may face issues while using their Webmail.
Posted Jul 27, 2026 - 12:24 BST
This incident affects: Email (Webmail).