Some websites may be inaccessible

Incident Report for ionos.co.uk

Update

Our technicians are currently working on resolving this issue.
Posted May 21, 2026 - 20:44 BST

Identified

Some customers may be experiencing issues accessing their websites.
Posted May 21, 2026 - 18:27 BST
This incident affects: Hosting (Wordpress Hosting).