We are still working on resolving this issue. More information will follow soon.
Posted Jan 10, 2025 - 11:55 GMT
Update
Our technicians are currently working on resolving this issue. Thank you for your patience and understanding.
Posted Jan 10, 2025 - 10:58 GMT
Identified
Due to a technical issue, functionalities for sending emails (e.g. contact form) of our MyWebsite product may be unavailable. We apologise for any inconvenience caused.
Posted Jan 10, 2025 - 09:18 GMT
This incident affected: Website Builder (MyWebsite NOW).