Incident Report for MyWebsite Now
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Oct 11, 2021 - 18:16 BST
Identified
Some customers may be experiencing issues accessing their websites.
Posted Oct 11, 2021 - 16:08 BST
This incident affected: Website Builder and Hosting (MyWebsite NOW).