Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 9 days ago. Jul 09, 2019 - 09:58 BST
Identified
We are experiencing an issue with our Contract Tool. In urgent cases please contact Customer Care via 0333 336 5780 to finalize the cancellation.
Posted 10 days ago. Jul 09, 2019 - 08:39 BST
This incident affected: Contract Management (Cancellation Service).