Access to Email Marketing may not be possible
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. We apologise for the inconvenience caused and thank you for your patience.
Posted Sep 17, 2024 - 10:04 BST
Update
We are currently working on resolving the technical disruption. We will have an update for you shortly.
Posted Sep 17, 2024 - 09:40 BST
Identified
Due to a technical disruption, accessing Email Marketing is not possible at this time.
Posted Sep 17, 2024 - 09:01 BST
This incident affected: Online Marketing (E-Mail Marketing).