Sending e-mails to Microsoft freemail accounts occasionally not possible
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Apr 17, 2020 - 10:29 BST
Identified
Some customers may be experiencing issues sending E-mails to Microsoft's Free Mail Services (Hotmail,parts of Outlook.com).
Posted Apr 15, 2020 - 17:16 BST
This incident affected: Mail System and Delivery (Sending Emails).