Disruption in several Control Panel areas
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Feb 19, 2020 - 12:43 GMT
Identified
During this time, configurations in some areas of your control panel may be limited.
Posted Feb 19, 2020 - 11:51 GMT
This incident affected: Control Panel.