Incident Report for Online Accounting
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted 3 months ago. Apr 17, 2019 - 12:14 BST
Identified
Some customers are experiencing issues while using their Online Accounting
Posted 3 months ago. Apr 17, 2019 - 11:34 BST
This incident affected: Email & Office (Online Accounting).