Some customers may be experiencing issues receiving E-mails.
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Feb 02, 2021 - 11:09 GMT
Identified
Some customers may be experiencing issues receiving E-mails. Our technicians are currently working on resolving this issue.
Posted Feb 02, 2021 - 10:48 GMT
This incident affected: Mail System and Delivery (Receiving Emails).