Website Accessibility Issues

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Sep 07, 2026 - 11:15 BST

Identified

Some customers are experiencing issues accessing their websites.
Posted Sep 07, 2026 - 10:58 BST
This incident affected: Website Builder (MyWebsite NOW).