Sending and receiving e-mails is currently not possible
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted Sep 11, 2020 - 10:30 BST
Identified
Some customers are experienceing isues when sending and receiving E-mails.
Posted Sep 11, 2020 - 09:24 BST
This incident affected: Mail System and Delivery (Sending Emails, Receiving Emails).