Incident Report for Mywebsite
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 27 days ago. May 31, 2019 - 09:00 BST
Identified
Access to Mywebsite in the Control Panel may be temporarily restricted.
Posted 27 days ago. May 31, 2019 - 08:53 BST
This incident affected: Website Builder and Hosting (MyWebsite (ordered before 09/06/2017)).