Greater hold time in our Hotline
Incident Report for ionos.co.uk
Resolved
This incident has been resolved.
Posted Jun 15, 2020 - 21:07 BST
Identified
Due to increased contact regarding .uk domain names, we are seeing an increased volume to our support lines. If you see an email from Nominet regarding the expiry of your .uk domain name that you didn't originally order, we were holding them for you as a goodwill gesture. This information does not regard any other domain extension apart from .uk domain name.

If you require more information or guidance, please try to contact us later or email transfers@ionos.co.uk for non-urgent questions.
Posted Jun 05, 2020 - 15:08 BST
This incident affected: Customer Service (Customer Hotline).