Some customers are unable to view their invoice in the Control Panel
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Nov 04, 2019 - 13:26 GMT
Identified
During this time, you will not be able to access your billing information through your Control Panel. Additionally, our Customer Service Team may not be able to answer all questions related to your account. We apologise for any inconvenience this may cause you.
Posted Nov 04, 2019 - 12:09 GMT
This incident affected: Contract Management (Billing Service).