Technical issues in our email systems

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Apr 21, 2026 - 15:31 BST

Update

Our technicians are currently working on resolving this issue.
Posted Apr 21, 2026 - 14:46 BST

Identified

Some customers may experience issue when using Webmail
Posted Apr 21, 2026 - 09:52 BST
This incident affected: Email (Webmail).