Incident Report for Customer Service Support Tool

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Nov 08, 2023 - 18:05 GMT

Identified

Due to a technical issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted Nov 08, 2023 - 16:36 GMT
This incident affected: Customer Service (Support Tool).