Incident Report for MyWebsite
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Jul 01, 2021 - 12:25 BST
Identified
Some customers are experiencing issues while using their MyWebsite.
Posted Jul 01, 2021 - 11:19 BST
This incident affected: Website Builder and Hosting (MyWebsite (ordered after 09/06/2017), MyWebsite (ordered before 09/06/2017)).