We are monitoring the situation to ensure that the issue does not reoccur.
Posted Apr 09, 2025 - 13:54 BST
Identified
Some customers are facing issues while using their MyWebsite product. At this time, it may not be possible to use the website editor. The online websites that have already been created may also be affected.
Posted Apr 09, 2025 - 13:34 BST
This incident affected: Website Builder (MyWebsite NOW).