Technical issues in our email systems

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Oct 27, 2025 - 15:54 GMT

Update

We are still working on resolving the technical issue.
Posted Oct 27, 2025 - 13:51 GMT

Identified

Some customers may be experiencing issues sending E-mails.
Posted Oct 27, 2025 - 10:30 GMT
This incident affected: Email (Webmail, Sending Emails).