Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted Oct 04, 2021 - 03:44 BST
Identified
Due to a technical disruption, there may be a delay setting up recently purchased products.
Posted Oct 03, 2021 - 15:11 BST
This incident affected: Contract Management (Contract Activation).