Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Feb 04, 2021 - 11:10 GMT
Identified
Some customers may be experiencing issues receiving E-mails.
Posted Feb 04, 2021 - 09:52 GMT
This incident affected: Mail System and Delivery (Receiving Emails).