Intermittent email issues to Hotmail, outlook.com and live.com addresses.
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted about 1 month ago. May 22, 2019 - 10:45 BST
Update
Our technicians are still working to rectify the issue with Microsoft. Please continue to retry sending your mail as not all emails are rejected. We will post an update as soon as new information becomes available.
Posted about 1 month ago. May 21, 2019 - 15:15 BST
Monitoring
Email sent to hotmail, outlook.com and live.com addresses may be intermittently rejected due to Microsoft blocking some of our IP addresses.We are aware of the issue and have contacted Microsoft to request de-listing.

As not all emails are rejected, we kindly ask you to resend your email again.

Please accept our apologises for any inconvenience caused.
Posted about 1 month ago. May 20, 2019 - 12:36 BST
This incident affected: Mail System and Delivery (Sending Emails).