Degraded performance with Webmail
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Our apologies for the inconvenience caused.
Posted Jun 26, 2024 - 16:35 BST
Identified
Due to a technical issue, some customers may not be able to access their emails by webmail and email client.
Posted Jun 26, 2024 - 15:59 BST
This incident affected: Email (Webmail).