Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted 13 days ago. May 12, 2019 - 17:22 BST
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 13 days ago. May 12, 2019 - 16:53 BST
This incident affected: Customer Service (Support Tool).