Email address creation may not be possible
Incident Report for ionos.co.uk
Resolved
The systems are stable and all services are functioning normally again.
Posted Jan 10, 2024 - 16:23 GMT
Identified
Some customers may be experiencing issues creating email address
Posted Jan 10, 2024 - 15:08 GMT
This incident affected: Control Panel.