Incident Report for MyWebsite
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Jul 14, 2021 - 16:24 BST
Identified
Some customers may experience issues while using their MyWebsite
Posted Jul 14, 2021 - 14:36 BST
This incident affected: Website Builder and Hosting (MyWebsite (ordered after 09/06/2017)).