Limited functionality of product Webmail

Incident Report for ionos.co.uk

Update

We have found the cause for the disruption and are working on resolving it.
Posted Aug 27, 2026 - 13:52 BST

Identified

We are still working on resolving the technical issue. Thank you for your patience.
Posted Aug 26, 2026 - 15:30 BST

Investigating

Some customers may face issues while using their Webmail.
Posted Aug 26, 2026 - 10:41 BST
This incident affects: Email (Webmail).