Incident Report
Incident Report for ionos.co.uk
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted 6 months ago. Mar 28, 2019 - 14:51 GMT
Identified
Due to a techncial issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted 6 months ago. Mar 28, 2019 - 13:36 GMT
This incident affected: Customer Service (Support Tool).