Support Hotline cannot be reached
Incident Report for ionos.co.uk
Resolved
The disruption affecting the Support Line has been resolved. It is now functioning normally again.
We apologise for the inconvenience caused and thank you for your patience.
Posted 3 months ago. Mar 07, 2019 - 16:48 GMT
Update
We are continuing to work on a fix for this issue.
Posted 3 months ago. Mar 07, 2019 - 16:31 GMT
Identified
An outage in one of our main offices is impacting our Technical Support line. You may experience a greater hold time than usual. We apologise for any inconvenience during these brief technical difficulties and appreciate your patience and understanding. We will continue to post updates as we make progress on these issues.

Please reach our customer care unit via e-mail at support@ionos.co.uk
Posted 3 months ago. Mar 07, 2019 - 16:30 GMT
This incident affected: Customer Service (Customer Hotline).