MyWebsite Editor and Live Sites Accessibility Issues

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Sep 17, 2025 - 11:23 BST

Update

We have eliminated the disruption for almost everyone affected.
Posted Sep 17, 2025 - 11:11 BST

Update

Our technicians are currently working on resolving this issue. Thank you for your patience and understanding.
Posted Sep 17, 2025 - 11:02 BST

Identified

Some customers are facing issues while using their MyWebsite product. The online websites that have already been created may also be affected.
Posted Sep 17, 2025 - 10:16 BST
This incident affected: Website Builder (MyWebsite NOW).