Incident Report for Mail Business
Incident Report for ionos.co.uk
Resolved
The systems are stable and all services are functioning normally again.
Posted Nov 09, 2020 - 11:30 GMT
Identified
Some customers may face issues while using their Mail Business
Posted Nov 09, 2020 - 11:20 GMT
This incident affected: Email (Webmail).