The issue has been resolved. We apologise to customers who were affected by this disruption. We are working to ensure that similar issues do not occur in the future.
Posted Sep 10, 2024 - 20:35 BST
Update
We are still working on resolving the technical issue. Thank you for your patience and understanding.
Posted Sep 10, 2024 - 14:08 BST
Update
Our technicians are currently working on resolving this issue.
Posted Sep 10, 2024 - 11:36 BST
Identified
Some customers are experiencing issues accessing their websites. Our apologies for the inconvenience caused.
Posted Sep 10, 2024 - 10:46 BST
This incident affected: Website Builder (MyWebsite NOW).