Technical issues in our email systems

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Jun 30, 2026 - 10:55 BST

Investigating

Some customers are experiencing issues while using their Microsoft Exchange.
Posted Jun 30, 2026 - 10:13 BST
This incident affected: Email (Microsoft Exchange).