Technical issues in our email systems

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Jul 21, 2025 - 12:30 BST

Update

We have successfully minimised the disruption and are working to completely resolve it as soon as possible.
Posted Jul 21, 2025 - 11:43 BST

Identified

Some customers may face issues while using their Webmail
Posted Jul 21, 2025 - 09:50 BST
This incident affected: Email (Webmail).