Access to E-Mail & Office in the Control Panel may be temporarily restricted.
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Jun 29, 2020 - 08:11 BST
Identified
Access to E-Mail & Office in the Control Panel may be temporarily restricted. We are currently working on resolving the technical disruption. We will have an update for you shortly.
Posted Jun 29, 2020 - 07:58 BST
This incident affected: Control Panel.