Email address creation may not be possible
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Aug 23, 2021 - 13:04 BST
Identified
Some customers may be experiencing issues creating email address
Posted Aug 23, 2021 - 11:55 BST
This incident affected: Control Panel.