IONOS page is temporarily inaccessible

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Oct 24, 2023 - 12:58 BST

Monitoring

We are monitoring the situation to ensure that the issue does not reoccur.
Posted Oct 24, 2023 - 12:55 BST

Identified

We are experiencing technical issues with our website https://www.ionos.co.uk
Posted Oct 24, 2023 - 12:38 BST
This incident affected: IONOS (IONOS Order Page).