Disruption in several Control Panel areas
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Jun 03, 2020 - 07:57 BST
Identified
During this time, configurations in some areas of your control panel may be limited.
Posted Jun 03, 2020 - 07:06 BST
This incident affected: Control Panel.