Limited functionality of product MyWebsite NOW

Incident Report for ionos.co.uk

Resolved

The issue has been resolved.
Posted Nov 18, 2025 - 00:51 GMT

Identified

Some customers are experiencing issues accessing their websites.
Posted Nov 17, 2025 - 23:46 GMT
This incident affected: Website Builder (MyWebsite NOW).