Incident Report for Microsoft Exchange 2019
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Apr 14, 2021 - 08:58 BST
Identified
Some customers are experiencing issues while using their Microsoft Exchange 2019.
Posted Apr 14, 2021 - 07:46 BST
This incident affected: Email (Microsoft Exchange).