Control Panel is inaccessible
Incident Report for ionos.co.uk
Resolved
The issue has been resolved.
Posted Jun 23, 2022 - 11:02 BST
Identified
Currently, some customers may not be able to log into the Control Panel
Posted Jun 23, 2022 - 10:35 BST
This incident affected: Control Panel.